Build dependencies

From FIFE development wiki
Jump to: navigation, search

Introduction

This page lists all dependencies that need to be installed to build FIFE from source.

Quick installs are available for Debian based systems (e.g. Ubuntu) and Win32 based systems.

Supported build environments

Supported compilers

Framework

SDL addon libraries

  • SDL_ttf >= 2.0
  • SDL_image - NOTE there have been issues using SDL-image version 1.2.9. Please use latest version! See trac ticket #410

Sound libraries

  • libvorbis
  • libvorbisfile
  • libogg
  • OpenAL

GUI / RAD libraries

  • guichan >= 0.8.2 for the ingame GUI. Don't install guichan via your package manager. Due to problems with package detection, a patched copy of guichan >= 0.8.2 resides in our Subversion repository and it will get automatically built later when you run scons ext.

Scripting-related libraries

Compression libraries

Linux specific

  • Xcursor

Optional libs

  • libopengl & libglu >= 1.3: for additional OpenGL support.
  • Qt4 for building Atlas Creator tool